Thursday, 1 May 2014

JQuery library conflicts on apex.oracle.com

APEX 4.2.3 vs. 4.2.5 version

Not sure if it happened to you too but when Oracle decided to upgrade their Application Express workspaces to 4.2.5 version some of my JavaScript scripts stopped working and Firebug started reporting: 

 
 

 My JQuery libraries that were included in the page under v4.2.3 were: 

<script src="http://code.jquery.com/ui/1.10.3/jquery-ui.js"></script>
<script src="http://code.jquery.com/jquery-1.8.3.min.js"> </script>
<link rel="stylesheet" href="http://code.jquery.com/ui/1.10.3/themes/smoothness/jquery-ui.css" />


solution was of course to replace them with newer set of libraries so I used:

<link rel="stylesheet" href="//code.jquery.com/ui/1.10.4/themes/smoothness/jquery-ui.css">
<script src="//code.jquery.com/jquery-1.10.2.js"></script>
<script src="//code.jquery.com/ui/1.10.4/jquery-ui.js"></script>

And all of the problems were gone. I just thought it might be useful to some of you out there. 


Cheers,
SLino


No comments:

Post a Comment